Our ticketing system has been successfully upgraded and is operational at this time.
Posted Jun 11, 2025 - 16:06 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 11, 2025 - 00:00 CDT
Scheduled
CHTC will be switching to a new email support/ticketing system on June 11th. You can still email us at chtc@cs.wisc.edu, and all open tickets should carry over automatically.
Please note: We may experience brief downtime or delayed responses during the transition.