We've fixed the issue and are working through the backlog of requests.
Posted Apr 10, 2026 - 13:30 CDT
Identified
An issue with our accounting system is preventing us from creating new CHTC accounts or modifying existing CHTC accounts. This does not affect anyone with an existing account nor their ability to login, but will delay us from creating accounts for new users or giving existing users access to new resources.
Posted Apr 09, 2026 - 16:56 CDT
This incident affected: CHTC Internal Infrastructure (RT Email/Ticket Support System).